3
$\begingroup$

Good day! I have a problem replicating a result. Let us consider the top plot here:

plots of seismograms

On the plot, velocity is in mm/s. I think the problem is to remove instrument response correctly. I downloaded seismogram and pole-zero instrument response. I want to obtain velocity data. The instrument response is already given in velocity. I was able to get synthetic seismograms as shown in the figure, but I have a problem working with real data.

I need a signal to be filtered in 0.001–0.004 Hz

Using IRIS SAC software, I do:

SAC> r KYK_BHZ
SAC> rmean
SAC> rtrend
SAC> taper
SAC> trans from polezero subtype KYK_LHZ.zp
SAC> bp p 2 n 4 c 0.001 0.004
  1. I do not set FREQlimits for transfer function at all here, but I tried to do it like 0.0009 0.001 0.004 0.005 or 0.0009 0.001 1 2, but it also doesn't work.
  2. My synthetic seismogram is 1 Hz data, so I don't do any resampling.
  3. I tried to do trans from polezero subtype KYK_LHZ.zp to vel, but it also doesn't work.

Both the data and zero-pole files are here.

Thanks!

$\endgroup$
  • $\begingroup$ Hi @NikkeyD, could you be more specific on what "it doesn't work" means? I was able to run those commands in SAC and ended up with something resembling your images. What time window, in seconds from the origin, 0, are you focusing on? $\endgroup$ – dergeophysiker Jan 14 '18 at 6:05
  • $\begingroup$ Sorry for misleading. I just meant that I cannot get results as shown on figure. My interest in time 06:26:01 (it is actually the black square on a figure and till ~06:45. Do you use same commands as written above or you do it in some other way? Thanks! $\endgroup$ – NikkeyD Jan 14 '18 at 22:01
2
$\begingroup$

I typed in the commands as shown using your data in SAC. I've uploaded my result. The plot window shows the result of the commands run in the highlighted red area. Is this what you are trying to do? The plot xlim is set from 1750 s to 2700 s.

analysis in SAC

$\endgroup$
  • 1
    $\begingroup$ It looks quite close, thanks! Seems I don't need to do any additional filtering and only play with freqlimits values? The problem is that on your plot the amplitudes ~0.0016 mm/s, whereas on plot above it is 0.016 mm/s... (As I know SAC gives in m/s?) Although, it is written in article: "Normalized vertical component of the ground velocity measured by selected seismometers of the broadband network". Normalized by factor of 10?... $\endgroup$ – NikkeyD Jan 15 '18 at 17:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.