I am new with Python so please be kind. I want to download data from ERA5 and so far I have installed the CDS API package and followed all the instructions from https://cds.climate.copernicus.eu/api-how-to

I have my main file ready to use but I get an error about the configuration file. I know that this file should contain the following:

url: https://cds.climate.copernicus.eu/api/v2
key: {UID}:{key}

I have created a text file and a configuration file with this info and I have placed them in the following address (as required by the error I get in python):


However, I still get the same error. What I am doing wrong? Do I need to create a different type of file? Do I need to write the user info in a different way?

Exception: Missing/incomplete configuration file: C:\Users\username/.cdsapirc

By the way, I'm using a windows computer.

  • $\begingroup$ why dont you contact Copernicus support and ask them ? Very few people in academic use Windows. Almost all are Linux users. Even if I want to help you where will I find a Windows box to test what you are reporting ? $\endgroup$
    – user1066
    May 20, 2019 at 8:39
  • $\begingroup$ @gansub eh, plenty of us use Windows. $\endgroup$ May 22, 2019 at 22:15
  • $\begingroup$ @SemidiurnalSimon Would be interesting to do a statistical analysis - Linux vs. Windows users. My guess is that Linux/UNIX would be in the majority. $\endgroup$
    – user1066
    May 23, 2019 at 1:05
  • $\begingroup$ @gansub I think you'll find it very field-dependant. Many of us use both, of course, but don't underestimate the need to have MS Word and Outlook ;-) $\endgroup$ May 23, 2019 at 5:38
  • $\begingroup$ @SemidiurnalSimon Well I get by with LibreOffice :-). And about Outlook never used it :-) $\endgroup$
    – user1066
    May 23, 2019 at 9:11

1 Answer 1


I had the same problem but have just found the solution after an hour or so of trawling through forums! The problem was that the code 'api.py' could not find the '.cdsapirc' file. The file type has to actually be 'CDSAPIRC' and not a 'txt' file. The icon for the file will then be displayed in your folder as blank and the name will be '.cdsapirc'. I found the solution on here: https://www.wikihow.com/Create-and-Delete-Files-and-Directories-from-Windows-Command-Prompt. I created the file using the following steps:

  1. Navigate to 'C:\Users\username' (or you can just move it later).
  2. In Command Prompt, write 'type nul > .cdsapirc' and press Enter.
  3. Right-click the file and press 'Edit with Notepad++' (probably works with other programs).
  4. Paste the text that you already mentioned (key, etc).
  5. Save and close the document.

Hope that works :)

  • 2
    $\begingroup$ There's an option to get Windows Explorer to show file extensions. I strongly recommend turning it on, so that you can tell the difference in this kind of scenario! $\endgroup$ May 22, 2019 at 22:16
  • 1
    $\begingroup$ Actually, I manage to found a simpler solution. So, I created a text file and I pasted the key and UID info. Then I saved it as .cdsapirc and selected All files (.) as file type. After that, I was able to download the data normally. Thank you for your help anyway, it led me into the right direction somehow. $\endgroup$ May 24, 2019 at 7:21
  • $\begingroup$ Ah yes, that is easier! I will post your answer on the ECMWF website, here confluence.ecmwf.int/pages/viewpage.action?pageId=139068264 $\endgroup$ May 24, 2019 at 10:49
  • 1
    $\begingroup$ Even after doing so (creating .cdsapirc file with proper info of UID and API key), I am getting same error. i have downloaded ERA-Interim data from same earlier). $\endgroup$ Jan 28, 2020 at 11:35

Not the answer you're looking for? Browse other questions tagged or ask your own question.