0
$\begingroup$

I am working on CO2 and CH4 by WRF-CHEM, for providing my anthropogenic emission from Edgar data base, I'm going to use the Prep_chem_source App.

I would like to use Edgar data emission (as my anthropogenic emission) for CO2-CH4 and simulate these gasses by WRF-CHEM. due to the Prep_chem_source instruction, I have done bellow steps:

  1. I consider chem_opt=0 and run the ./real.exe
  2. Run ./prep_chem_source.exe
  3. Link the output of files of step 2, to my em_real directory (emissopt3_d01,...)
  4. Change namelist.input chem_opt in to 17, chem_opt=17
  5. Run ./convert_emiss.exe

But ./convert doesn't make wrfchemi_d01 ,wrffirechemi_d02,... what shall I do to have E_CO2, E_CH4,...as my anthropogenic emission from Edgar, using prep_source?

It is a part of my name list:

&time_control
run_days                 = 0,
run_hours                = 30,
run_minutes              = 0,
run_seconds              = 0,
start_year               = 2007, 2007,
start_month              = 08, 08,
start_day                = 1,  1,
start_hour               = 18,       18,
start_minute             = 00,       00,
start_second             = 00,       00,
end_year                 = 2010, 2010,
end_month                = 08, 08,
end_day                  = 03, 03,
end_hour                 = 00,      00,
end_minute               = 00,       00,
end_second               = 00,       00,
input_from_file          = .true.,   .true.,
interval_seconds         = 21600,
history_outname          = "wrfout<domain>_<date>",
frames_per_auxinput5     = 2,    2,
auxinput5_inname         = "wrfchemi_d<domain>_<date>",
auxinput5_interval_m     = 1440,  1440,
io_form_auxinput5        = 2,
frames_per_auxinput7     = 2,    2,
auxinput7_inname         = "wrffirechemi_d<domain>_<date>",
auxinput7_interval_m     = 1440,  1440,
io_form_auxinput7        = 2,
history_interval         = 60,      60,
frames_per_outfile       = 1000,     1000,
restart                  = .false.,
write_hist_at_0h_rst     = .true.,
restart_interval         = 360,
io_form_history          = 2,
io_form_restart          = 2,
io_form_input            = 2,
io_form_boundary         = 2,
debug_level              = 0,
/
&physics
mp_physics               = 10,        10,  ! 3,        3,
ra_lw_physics            = 1,        1,
ra_sw_physics            = 1,        1,
radt                     = 30,       2,
sf_sfclay_physics        = 1,        1,
sf_surface_physics       = 2,        2,
bl_pbl_physics           = 8,        8,  ! 1,        1,
bldt                     = 0,        0,
cu_physics               = 3,        3,  ! 3,        3,
cudt                     = 0,        0,  ! 5,        5,
isfflx                   = 1,
ifsnow                   = 1,
icloud                   = 1,
surface_input_source     = 1,
num_soil_layers          = 4,
! sf_urban_physics       = 0,    0,
cu_diag                  = 1,  1,
cugd_avedx               = 1,    !  3,
cu_rad_feedback          = .true.,   .true.,
maxiens                  = 1,
maxens                   = 3,
maxens2                  = 3,
maxens3                  = 16,
ensdim                   = 144,
/

&chem
 chem_opt                            = 17,  17,
 vertmix_onoff                       = 1,  1,
 have_bcs_chem                       = .true., .true.,
!! have_bcs_tracer                     = .false., .false.,
 chem_in_opt                         = 0,  0,
 term_opt                            = "CH4_termite_OW", "CH4_termite_OW",
 emiss_inpt_opt                      = 16,  16,
 emiss_opt                           = 17, 17,
 chem_conv_tr  
! bb_opt_ghg                          = 0, 0,
 biomass_burn_opt                    = 5,   5, ! 0,  0,
 !plumerisefire_frq                   = 60, 60,
 io_style_emissions                  = 2,
 kemit                               = 1,
 bioemdt                             = 30, 30,
 photdt                              = 30,  30,
 chemdt                              = 1.,  1.,
 phot_opt                            = 0,   0,
 bio_emiss_opt                       = 1,   1,
 conv_tr_wetscav                     = 0,   0,
 gas_bc_opt                          = 0,   0,
 gas_ic_opt                          = 0,   0,
 aer_bc_opt                          = 0,   0,
 aer_ic_opt                          = 0,   0,
 gaschem_onoff                       = 0,   0,
 aerchem_onoff                       = 0,   0,
 wetscav_onoff                       = 0,   0,
 cldchem_onoff                       = 0,   0,
 aer_ra_feedback                     = 0,   0,
 vprm_opt                            = "VPRM_table_TROPICS", "VPRM_table_TROPICS",
 gas_drydep_opt                      = 0,   0,
/
$\endgroup$
11
  • $\begingroup$ Do you get any error messages? I am not familiar with the emission preprocessing routines of WRF. Therefore, I am guessing a bit (since no one else commented yet): Which version of the EDGAR emissions are you using? Which namelist file did you modify? According to this talk one needs to modify the namelists in prep_chem_sources.inp (e.g. slide 19: add option use_edgar). Not sure, if this presentation refers to the version of WRF that you are using. $\endgroup$ – daniel.heydebreck May 26 '20 at 7:24
  • $\begingroup$ hi dear daniel.heydebreck, thanks for the response. I didn't get any error. the prep_chem_source doesn't make any emission file(wrfchemi,wrffirechemi,...).I am working with wrf.3.9.1.1.in addition i use _edgar ( use_edgar =3, ! 0 - not,! 1 - Version 3, ! 2 - Version 4 for some species ! 3 - Version HTAP),2 and 3. you know? I need to have E_CO2 and E_CH4 as my anthropogenic emission from Edgar.I have chosen (chem_opt=16 or 17)(the greenhouse gases chemistry option in user guide of wrf-chem). I don't know how can I have anthropogenic emission for CO2 and CH4? $\endgroup$ – sara May 26 '20 at 9:21
  • $\begingroup$ Which EDGAR data did you download? The EDGAR-HTAP dataset should only contain air pollutants (and no greenhouse gases). Could you provide an URL? Did you download the netCDF or txt data? $\endgroup$ – daniel.heydebreck May 26 '20 at 13:19
  • $\begingroup$ I am working on the almost the middle east and the prep_chem source uses the data of Global emission version 3.it has (EDGAR-HTAP, Edgar,...(aftp.fsl.noaa.gov/divisions/taq/global_emissions) they are all old and are for 2005.txt and it has not any unit!). but in the Edgar web site, it has EDGAR emission V5(in 2 formats of txt(ton) and NetCDF(kg/m2s). what shall I do to make anthropogenic emission?(hourly)?prep_chem_source? by which name list? I would like to have E_CO2 and E_CH4? thank you ... $\endgroup$ – sara May 26 '20 at 20:51
  • $\begingroup$ If I download the global_emissions_v3_24aug2015.tar.gz from the FTP Server, then I find three folders with EDGAR emission datasets in it: EDGAR, EDGAR-HTAP and EDGARV4. The first and third folder contain emissions for greenhouse gases in txt format. Probably EDGAR contains verion 3 EDGAR emissions. The second folder contains emissions of air pollutants in h5 format (HDF5). ... $\endgroup$ – daniel.heydebreck May 26 '20 at 21:37
0
$\begingroup$

have you solved the problem? I also met the same difficulties as you and I've stucked here for seveal days. Could you share how you solved this problem? Thank you very much!

New contributor
Zhao Yang is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.