1
$\begingroup$

I get the following error messages when running the hydrological model MIKE-SHE:

"Cannot initialize MIKE-1D - Failed when solving for a steady state solution; water level being exceeded; Warning: Hyperthreading"

I managed to get all my grid sizes to match the domain and finally got rid of the abnormal termination because of grid issues. In the pre-processing, it seems that all my other files were also fine i.e. see below from SimSpec and storing to Overland Data. However, when it gets to River Data I get an error in loading MIKE 1D d11… see below. I redid my MikeHydro with the same DEM as now in my MikeShe and I still get the same errors.

I would be extremely grateful for any assistance on this issues of initialising Mike 1D

Screen grab of error

$\endgroup$
11
  • $\begingroup$ Advice given: Try running the MIKE HYDRO model on its own. That will help trying to figure out the error. Also check the log file (.txt file) in Windows Explorer folder that you have your model saved in. Doing both of these will assist in why you may be getting the error message in MIKE SHE. $\endgroup$
    – ecohydrol
    Jul 25 at 13:00
  • $\begingroup$ I had not recalculated the Q/h boundary so now that I did this, it seems to get past the beta error originally mentioned, but then I got some new errors about water level being exceeded on 9 grid points (see second message below). So, I checked, and it looked like these were the 9 cross sections that I inserted manually and only made 200 meters in comparison to all my others which were around 400 meters. So, I lengthened these cross sections with the extend tool. My simulation has now run. See message file below. I still get a warning about hyper threading. [![message file below](i.sta $\endgroup$
    – ecohydrol
    Jul 25 at 13:05
  • $\begingroup$ Sorry, I just realised that I did not recalculate the Q/h boundary after I extended the cross sections when I do this the simulation still runs but I get the following warning: ‘Q values in QH boundary not monotonically increasing’ ….. I think this might be due to the geometry of the cross sections. But I do not think I will run my mike she until I have sorted this out. $\endgroup$
    – ecohydrol
    Jul 25 at 13:07
  • $\begingroup$ Thanks Weiss, I'm busy exploring the capabilities of Earth Science Stack Exchange for our hydrological modelling community. We would like to consider using it to support our community of practice. Going forward we will be encouraging users and students to post their questions on this site where they will be answered, resulting in better efficiency and transparency, and supporting the global hydrological modelling community. However for now, we have some commonly asked Q&A's to get this started, and also some documented Q&A's. This is the latter. $\endgroup$
    – ecohydrol
    Jul 25 at 13:51
  • 1
    $\begingroup$ Let us continue this discussion in chat. $\endgroup$
    – ecohydrol
    Jul 26 at 19:27

1 Answer 1

1
$\begingroup$

Looking at your cross-section file, there are some that need to be corrected. Have a look at the screenshot below. All your branches contain at least one cross-section that has its lowest elevation point at 0m. this needs to be corrected to be consistent with your other cross-sections.

As a result of the bottom cross-section being 0m, you’ll need to redo the Q/h relationship for the outflow cross-section. Looking at the ones above, this should be between 450 – 500 m (meters above sea level). Once you’ve corrected these, hopefully the model will run. cross section errors

$\endgroup$
2
  • 1
    $\begingroup$ I have managed to now change these cross sections. They were definitely not picking up the DEM because of how I inserted them so using the move option as you mentioned worked perfectly. I have rerun the simulation and now it runs without any errors or warning messages. I have also managed to run the preprocessing in Mike-SHE now successfully $\endgroup$
    – ecohydrol
    Jul 25 at 13:10
  • 2
    $\begingroup$ Hi please write one long answer rather than 3! $\endgroup$
    – Weiss
    Jul 25 at 13:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.