12
$\begingroup$

I have tried to convert a Seismic SU file to ASCII format in seismic unix using openseaseis module named "sutoascii".

I have already tested the SU file by opening it in SeaView Seismic Viewer and then tried to convert it to "ASCII" format using the following command:

sutoascii <inputSUFilename >outputASCIIFilename bare=0 index=1

The ASCII file is created as an output file but it gives an error while converting that "number of samples in header differs from number for first trace"

Now to check whether the Resulting ASCIIFile is valid and working, I have tried to open it in SeaView Seismic Viewer again to cross-check but it shows an error and is unable to open the file.

Can anybody tell me how to correct this?

$\endgroup$
  • $\begingroup$ If this is a command line, shouldn't "bare=0" and "index=1" come before the first redirect symbol? $\endgroup$ – Barry Carter Nov 23 '14 at 0:54
  • $\begingroup$ @BarryCarter yes, this is a command line and its not necessary for it to come before the first redirect symbol. For reference regarding syntax, please refer to seismicunix.com/w/Suascii $\endgroup$ – abhinavgoyal02 Nov 26 '14 at 11:07
  • $\begingroup$ That page says nothing about where options go, but ">" and "<" are interpreted by the shell, not by sutoascii. The program doesn't even see "bare=0" and "index=1" above. $\endgroup$ – Barry Carter Nov 26 '14 at 12:05
  • $\begingroup$ @abhinavgoyal02 - It would be nice to know how this ended... did the answer here help? What did you actually end up doing? $\endgroup$ – kwinkunks May 12 '15 at 16:59
5
$\begingroup$

The number of samples in the input binary header from the SEGY file does not match the NSAMP trace header. I would first confirm:

  1. What # of samples is in the binary SEG-Y header.
  2. The number of samples you expect in each trace
  3. Dump the su trace header for number of samples. You can use SUGETHW and the keyword for # of samples is "ns".

If the error is in an individual trace header, you can overwrite that with SUSETHW.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.